Question about Mencoder?

0 like 0 dislike
2 views
After converting multi-channel audio (usually 4, 5, or 6 channels) to a stereo volume drops significantly.


Convert video to flv format like the following:

#!/bin/sh

AVI=$1
FLV=`echo "$AVI" | sed -e 's/\\.avi$//"
NW=360

# here "cleverly" calculated numbers with the size of the picture to decrease
WI=`avinfo $AVI | grep video: | awk '{print $2}' | awk -Fx '{print $1}"
HE=`avinfo $AVI | grep video: | awk '{print $2}' | awk -Fx '{print $2}"

NH=`calc "print $NW * $HE / $WI" | sed -e 's/^~//' | awk -F. '{print $1}"

# conversion
mencoder \\
$AVI \\
-ofps 15 \\
-o $FLV \\
-of lavf \\
-oac mp3lame \\
-lameopts abr:br=56:mode=1:padding=1 \\
-srate 44100 \\
-ovc lavc \\
-lavcopts vcodec=flv:keyint=25:vbitrate=320:mbd=2:mv0:trell:v4mv:cbp:last_pred=3 \\
-vf scale=$NW:$NH

# transfer video titles in the beginning to seek
flvmeta $FLV $FLV.flv



Thus, if the channels sound file is larger than 2, the sound is very quiet.

Tried different audio filters to use in the manual (and hrtf channels), but the result is zero.

Conventional stereo-mono overtired and shouts loudly.

Actually the question is what to prescribe in mencoder in the settings, the sound is mixed correctly from all channels in stereo?
by | 2 views

3 Answers

0 like 0 dislike
He found the answer, helped me -af hrtf=s,resample=44100:0:0,volnorm
The sound seems to become better and louder.
by
0 like 0 dislike
af volume=NN not tried?
by
0 like 0 dislike
I experienced a similar problem with ffmpeg-Ohm. in the end had to patch libavcodec_resample (found somewhere in the e-mail lists... then the mixing of the channels started to work fine...
by

Related questions

0 like 0 dislike
3 answers
0 like 0 dislike
7 answers
asked Mar 23, 2019 by TheHorse
0 like 0 dislike
2 answers
0 like 0 dislike
3 answers
0 like 0 dislike
7 answers
110,608 questions
257,186 answers
0 comments
28,857 users