How to install gcc on Scientific Linux release 6.4?


Warning: count(): Parameter must be an array or an object that implements Countable in /home/styllloz/public_html/qa-theme/donut-theme/qa-donut-layer.php on line 274
0 like 0 dislike
15 views
Can't install gcc (needed to install VirtualBox):

# yum install gcc Loaded plugins: dellsysid, security Setting up Install Process Resolving Dependencies --> Running transaction check ---> Package gcc.x86_64 0:4.4.6-3.el6 will be installed --> Processing Dependency: cpp = 4.4.6-3.el6 for package: gcc-4.4.6-3.el6.x86_64 --> Processing Dependency: libgomp = 4.4.6-3.el6 for package: gcc-4.4.6-3.el6.x86_64 --> Processing Dependency: glibc-devel >= 2.2.90-12 for package: gcc-4.4.6-3.el6.x86_64 --> Processing Dependency: cloog-ppl >= 0.15 for package: gcc-4.4.6-3.el6.x86_64 --> Running transaction check ---> Package cloog-ppl.x86_64 0:0.15.7-1.2.el6 will be installed --> Processing Dependency: libppl_c.so.2()(64bit) for package: cloog-ppl-0.15.7-1.2.el6.x86_64 --> Processing Dependency: libppl.so.7()(64bit) for package: cloog-ppl-0.15.7-1.2.el6.x86_64 ---> Package cpp.x86_64 0:4.4.6-3.el6 will be installed --> Processing Dependency: libmpfr.so.1()(64bit) for package: cpp-4.4.6-3.el6.x86_64 ---> Package glibc-devel.x86_64 0:2.12-1.47.el6 will be installed --> Processing Dependency: glibc-headers = 2.12-1.47.el6 for package: glibc-devel-2.12-1.47.el6.x86_64 --> Processing Dependency: glibc = 2.12-1.47.el6 for package: glibc-devel-2.12-1.47.el6.x86_64 --> Processing Dependency: glibc-headers for package: glibc-devel-2.12-1.47.el6.x86_64 ---> Package libgomp.i686 0:4.4.6-3.el6 will be installed --> Running transaction check ---> Package glibc.i686 0:2.12-1.47.el6 will be installed --> Processing Dependency: glibc-common = 2.12-1.47.el6 for package: glibc-2.12-1.47.el6.i686 --> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.12-1.47.el6.i686 --> Processing Dependency: libfreebl3.so for package: glibc-2.12-1.47.el6.i686 ---> Package glibc-headers.x86_64 0:2.12-1.47.el6 will be installed ---> Package mpfr.x86_64 0:2.4.1-6.el6 will be installed ---> Package ppl.x86_64 0:0.10.2-11.el6 will be installed --> Running transaction check ---> Package glibc.i686 0:2.12-1.47.el6 will be installed --> Processing Dependency: glibc-common = 2.12-1.47.el6 for package: glibc-2.12-1.47.el6.i686 ---> Package nss-softokn-freebl.i686 0:3.14.3-3.el6_4 will be installed --> Finished Dependency Resolution Error: Package: glibc-2.12-1.47.el6.i686 (os) Requires: glibc-common = 2.12-1.47.el6 Installed: glibc-common-2.12-1.132.el6.x86_64 (@security) glibc-common = 2.12-1.132.el6 Available: glibc-common-2.12-1.47.el6.x86_64 (os) glibc-common = 2.12-1.47.el6 You could try using --skip-broken to work around the problem ** Found 10 pre-existing rpmdb problem(s), 'yum check' output follows: pl-6.4.1-1.el6.x86_64 has missing requires of libarchive.so.2()(64bit) pl-6.4.1-1.el6.x86_64 has missing requires of libossp-uuid.so.16()(64bit) pl-compat-yap-devel-6.4.1-1.el6.x86_64 has missing requires of pl-devel = ('0', '6.4.1', '1.el6') pl-jpl-6.4.1-1.el6.x86_64 has missing requires of java pl-jpl-6.4.1-1.el6.x86_64 has missing requires of jpackage-utils pl-jpl-6.4.1-1.el6.x86_64 has missing requires of libjava.so()(64bit) pl-jpl-6.4.1-1.el6.x86_64 has missing requires of libjvm.so()(64bit) pl-jpl-6.4.1-1.el6.x86_64 has missing requires of libjvm.so(SUNWprivate_1.1)(64bit) pl-jpl-6.4.1-1.el6.x86_64 has missing requires of libverify.so()(64bit) pl-static-6.4.1-1.el6.x86_64 has missing requires of readline-devel


Looks like it's trying to put glibc.i686 0:2.12-1.47.since glibc el6.is x86_64 not the same version.
yum list installed glibc Loaded plugins: dellsysid, security Installed Packages glibc.x86_64 2.12-1.132.el6 @security


How am I supposed to win? Reinstall not offer, the server is not mine, all sorts of things are already spinning.
by | 15 views

1 Answer

0 like 0 dislike
glibc-devel wants to come old.
Updating via "yum update" no packages are not helping?
If not, then show the list of active repositories.
by

Related questions

0 like 0 dislike
2 answers
0 like 0 dislike
1 answer
0 like 0 dislike
1 answer
0 like 0 dislike
3 answers
110,608 questions
257,186 answers
0 comments
28,014 users