Ubuntu+LVM2+Grub2 — new install on another computer


Warning: count(): Parameter must be an array or an object that implements Countable in /home/styllloz/public_html/qa-theme/donut-theme/qa-donut-layer.php on line 274
0 like 0 dislike
7 views
Put Ubuntu on this manual onto an external usb hard. On this lvm partition, it should and Ubuntu, and rude. The system worked fine. Connected the hard to another computer — the rough starts fine, but after you select OS black screen and then a blinking cursor, the development ends.

Booted from internal hard, did update-grub. Grub2 is installed on the internal hard, saw the system on the outside, added it to the list, but when I try to load the same picture.

Turns out, Grub is working fine, but the core shows no signs of loading. "quiet splash" replaced with "nosplash". Errors are seen. The piece of config:

menuentry 'Ubuntu, with Linux 2.6.35-26-generic' --class ubuntu --class gnu-linux --class gnu --class os {
recordfail
insmod lvm
insmod part_msdos
insmod ext2
set root='(local-root)'
search --no-floppy --fs-uuid --set 675a12ce-9946-42c8-84ac-0b72f2ff88f4
linux /boot/vmlinuz-2.6.35-26-generic root=/dev/mapper/local-root ro nosplash
initrd /boot/initrd.img-2.6.35-26-generic
}


How to revive the system?
by | 7 views

1 Answer

0 like 0 dislike
I had a similar situation on the old distribe Ubuntu with Grub legacy.
Was school "--set 675a12ce-9946-42c8-84ac-0b72f2ff88f4".
by

Related questions

0 like 0 dislike
2 answers
0 like 0 dislike
5 answers
0 like 0 dislike
1 answer
asked Apr 12, 2019 by artyvr
0 like 0 dislike
1 answer
asked Apr 5, 2019 by MorozovNsk
0 like 0 dislike
1 answer
asked Apr 1, 2019 by MorozovNsk
110,608 questions
257,186 answers
0 comments
27,924 users