Why npm swears on addiction, which supposedly is not?


Warning: count(): Parameter must be an array or an object that implements Countable in /home/styllloz/public_html/qa-theme/donut-theme/qa-donut-layer.php on line 274
0 like 0 dislike
51 views
Trying to install ngx-bootstrap through npm.

Receive here such error

ngx-bootstrap@2.0.4 requires a peer of @angular/common@>=4.3.0 || >5.0.0 but none was installed.
ngx-bootstrap@2.0.4 requires a peer of @angular/core@>=4.3.0 || >5.0.0 but none was installed.
ngx-bootstrap@2.0.4 requires a peer of @angular/forms@>=4.3.0 || >5.0.0 but none was installed.


But I'm all set
tsconfig.json
"@angular/animations": "^5.2.10", "@angular/common": "^5.2.10", "@angular/compiler": "^5.2.10", "@angular/compiler-cli": "^5.2.10", "@angular/core": "^5.2.10", "@angular/forms": "^5.2.10", "@angular/http": "^5.2.10", "@angular/platform-browser": "^5.2.10", "@angular/platform-browser-dynamic": "^5.2.10", "@angular/platform-server": "^5.2.10", "@angular/router": "^5.2.10",


Please tell me how that zaborot?
And then I set ngx-table-and css, apparently, just because ngx-bootstrap.
by | 51 views

1 Answer

0 like 0 dislike
It's not even a bug but,.. As a rule, if the installed version of angular is higher than that specified in warning, it usually can be ignored. But if below, then it's probably better to be updated.

In this particular case it probably has nothing to do with the problem styles.
by

Related questions

0 like 0 dislike
1 answer
0 like 0 dislike
1 answer
asked May 23, 2019 by EnChikiben
0 like 0 dislike
2 answers
0 like 0 dislike
2 answers
asked Apr 5, 2019 by IvanWebProgrammer
0 like 0 dislike
1 answer
110,608 questions
257,187 answers
0 comments
40,796 users