I have error when trying to deploy to dokku?


Warning: count(): Parameter must be an array or an object that implements Countable in /home/styllloz/public_html/qa-theme/donut-theme/qa-donut-layer.php on line 274
0 like 0 dislike
25 views
Hello!
Trying to deploy using dokku, when you run collectstatic --noinput occurs obscure bug.
The website is based even on another server using dokku too, there everything is OK.
If off collectstatic, then the same error appears the next step -----> Running post-compile hook.

-----> $ python manage.py collectstatic --noinput
Traceback (most recent call last):
File "manage.py", line 10, in
execute_from_command_line(sys.argv)
File "/app/.heroku/python/lib/python2.7/site-packages/django/core/management/__init__.py", line 385, in execute_from_command_line
utility.execute()
File "/app/.heroku/python/lib/python2.7/site-packages/django/core/management/__init__.py", line 354, in execute
django.setup()
File "/app/.heroku/python/lib/python2.7/site-packages/django/__init__.py", line 21, in setup
apps.populate(settings.INSTALLED_APPS)
File "/app/.heroku/python/lib/python2.7/site-packages/django/apps/registry.py", line 85, in populate
app_config = AppConfig.create(entry)
File "/app/.heroku/python/lib/python2.7/site-packages/django/apps/config.py", line 87, in create
module = import_module(entry)
File "/app/.heroku/python/lib/python2.7/importlib/__init__.py", line 37, in import_module
__import__(name)
File "/app/.heroku/python/lib/python2.7/site-packages/autocomplete_light/__init__.py", line 7, in
from .shortcuts import * # noqa
File "/app/.heroku/python/lib/python2.7/site-packages/autocomplete_light/shortcuts.py", line 7, in
from .forms import *
File "/app/.heroku/python/lib/python2.7/site-packages/autocomplete_light/forms.py", line 443, in
GenericM2MRelatedObjectDescriptorhandlingmixin, forms.ModelForm)):
File "/app/.heroku/python/lib/python2.7/site-packages/autocomplete_light/forms.py", line 282, in __new__
attrs)
File "/app/.heroku/python/lib/python2.7/site-packages/django/forms/models.py", line 245, in __new__
new_class = super(ModelFormMetaclass, mcs).__new__(mcs, name, bases, attrs)
File "/app/.heroku/python/lib/python2.7/site-packages/django/forms/forms.py", line 85, in __new__
.__new__(mcs, name, bases, attrs))
File "/app/.heroku/python/lib/python2.7/site-packages/django/forms/widgets.py", line 143, in __new__
.__new__(mcs, name, bases, attrs))
TypeError: Error when calling the metaclass bases
metaclass conflict: the metaclass of a derived class must be a (non-strict) subclass of the metaclasses of all its bases

! Error while running '$ python manage.py collectstatic --noinput'.
See traceback above for details.

You may need to update application code to resolve this error.
Or, you can disable collectstatic for this application:

$ heroku config:set DISABLE_COLLECTSTATIC=1

https://devcenter.heroku.com/articles/django-assets
by | 25 views

1 Answer

0 like 0 dislike
Here the problem is not static.

Update package django-autocomplete-light to help you.

For more details see here
by

Related questions

0 like 0 dislike
1 answer
0 like 0 dislike
1 answer
asked Apr 14, 2019 by dim_nikita
0 like 0 dislike
2 answers
110,608 questions
257,187 answers
0 comments
40,796 users